#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d*?(9)|\d*?(8)|\d*?(7)|\d*?(6)|\d*?(5)|\d*?(4)|\d*?(3)|\d*(2)|\d*(1))(?:\d*(9)|\d*(8)|\d*(7)|\d*(6)|\d*(5)|\d*(4)|\d*(3)|\d*(2)|\d*(1))"
Local $sString = "987654321111111" & @CRLF & _
"811111111111119" & @CRLF & _
"234234234234278" & @CRLF & _
"818181911112111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")