// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d*?(9)|\d*?(8)|\d*?(7)|\d*?(6)|\d*?(5)|\d*?(4)|\d*?(3)|\d*(2)|\d*(1))(?:\d*(9)|\d*(8)|\d*(7)|\d*(6)|\d*(5)|\d*(4)|\d*(3)|\d*(2)|\d*(1))").unwrap();
let string = "987654321111111
811111111111119
234234234234278
818181911112111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}