const regex = /^(?:\d*?(9)|\d*?(8)|\d*?(7)|\d*?(6)|\d*?(5)|\d*?(4)|\d*?(3)|\d*(2)|\d*(1))(?:\d*(9)|\d*(8)|\d*(7)|\d*(6)|\d*(5)|\d*(4)|\d*(3)|\d*(2)|\d*(1))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d*?(9)|\\d*?(8)|\\d*?(7)|\\d*?(6)|\\d*?(5)|\\d*?(4)|\\d*?(3)|\\d*(2)|\\d*(1))(?:\\d*(9)|\\d*(8)|\\d*(7)|\\d*(6)|\\d*(5)|\\d*(4)|\\d*(3)|\\d*(2)|\\d*(1))', 'gm')
const str = `987654321111111
811111111111119
234234234234278
818181911112111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}