$re = '/^(?:\d*?(9)|\d*?(8)|\d*?(7)|\d*?(6)|\d*?(5)|\d*?(4)|\d*?(3)|\d*(2)|\d*(1))(?:\d*(9)|\d*(8)|\d*(7)|\d*(6)|\d*(5)|\d*(4)|\d*(3)|\d*(2)|\d*(1))/m';
$str = '987654321111111
811111111111119
234234234234278
818181911112111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);