# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\d\d:\d\d:\d\d\K,(?=\d\d\d\b)/./gm;t' <<< "00:01:17,000"