const regex = /\b\d\d:\d\d:\d\d\K,(?=\d\d\d\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d\\d:\\d\\d:\\d\\d\\K,(?=\\d\\d\\d\\b)', 'gm')
const str = `00:01:17,000`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);