re = /\b\d\d:\d\d:\d\d\K,(?=\d\d\d\b)/m
str = '00:01:17,000'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result