using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d\d:\d\d:\d\d\K,(?=\d\d\d\b)";
string substitution = @".";
string input = @"00:01:17,000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}