$re = '/\b\d\d:\d\d:\d\d\K,(?=\d\d\d\b)/m';
$str = '00:01:17,000';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;