use strict;
my $str = '00:01:17,000';
my $regex = qr/\b\d\d:\d\d:\d\d\K,(?=\d\d\d\b)/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";