#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ",(?=\D)"
Local $sString = "rgb(243,231,231),rgba(12,0,0,0.48)" & @CRLF & _
"hsl(0,80%,70%),#bada55" & @CRLF & _
"hsl(0,80%,70%),#bada55" & @CRLF & _
"red,red 60%,blue" & @CRLF & _
"" & @CRLF & _
"yellow,blue 20%,#0f0" & @CRLF & _
"" & @CRLF & _
"blue,green 40%,red" & @CRLF & _
"red,orange,yellow,green,blue,indigo,violet" & @CRLF & _
"red,rgba(255,0,0,0)" & @CRLF & _
"red,rgb(255,0,0)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")