using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=\D)";
string input = @"rgb(243,231,231),rgba(12,0,0,0.48)
hsl(0,80%,70%),#bada55
hsl(0,80%,70%),#bada55
red,red 60%,blue
yellow,blue 20%,#0f0
blue,green 40%,red
red,orange,yellow,green,blue,indigo,violet
red,rgba(255,0,0,0)
red,rgb(255,0,0)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}