use strict;
my $str = 'rgb(243,231,231),rgba(12,0,0,0.48)
hsl(0,80%,70%),#bada55
hsl(0,80%,70%),#bada55
red,red 60%,blue
yellow,blue 20%,#0f0
blue,green 40%,red
red,orange,yellow,green,blue,indigo,violet
red,rgba(255,0,0,0)
red,rgb(255,0,0)
';
my $regex = qr/,(?=\D)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}