$re = '/,(?=\D)/';
$str = 'rgb(243,231,231),rgba(12,0,0,0.48)
hsl(0,80%,70%),#bada55
hsl(0,80%,70%),#bada55
red,red 60%,blue
yellow,blue 20%,#0f0
blue,green 40%,red
red,orange,yellow,green,blue,indigo,violet
red,rgba(255,0,0,0)
red,rgb(255,0,0)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);