import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?=\\D)";
final String string = "rgb(243,231,231),rgba(12,0,0,0.48)\n"
+ "hsl(0,80%,70%),#bada55\n"
+ "hsl(0,80%,70%),#bada55\n"
+ "red,red 60%,blue\n\n"
+ "yellow,blue 20%,#0f0\n\n"
+ "blue,green 40%,red\n"
+ "red,orange,yellow,green,blue,indigo,violet\n"
+ "red,rgba(255,0,0,0)\n"
+ "red,rgb(255,0,0)\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}