# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r",(?=\D)"
test_str = ("rgb(243,231,231),rgba(12,0,0,0.48)\n"
"hsl(0,80%,70%),#bada55\n"
"hsl(0,80%,70%),#bada55\n"
"red,red 60%,blue\n\n"
"yellow,blue 20%,#0f0\n\n"
"blue,green 40%,red\n"
"red,orange,yellow,green,blue,indigo,violet\n"
"red,rgba(255,0,0,0)\n"
"red,rgb(255,0,0)\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.