#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<=Materi.l )\D+"
Local $sString = "produkt: Tričko, Rozměr 1x1x1cm, Material Aloe Vera 200g A_203" & @CRLF & _
"produkt: Tričko, Rozměr 2x3x2cm, Material Aloe 203" & @CRLF & _
"produkt: Tričko, Rozměr 2x3cm, Materiál Bavlna 400g N_W245_2017" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")