import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{0,72}$)(vim-patch.*|(fix|feat|docs|test|perf|refactor|chore|build)(\\([^)]+\\))?!?:\\s[a-z].*[^.]$)";
final String string = "feat(api): this is great \n"
+ "vim-patch:supportsanything\n"
+ "fix!: breaking change support\n"
+ "feat: No uppercase at start\n"
+ "feat: not ending with dot.\n"
+ "feat: too long of a commit message is not allowed over 71 characters long\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}