$re = '/^(?=.{0,72}$)(vim-patch.*|(fix|feat|docs|test|perf|refactor|chore|build)(\([^)]+\))?!?:\s[a-z].*[^.]$)/m';
$str = 'feat(api): this is great
vim-patch:supportsanything
fix!: breaking change support
feat: No uppercase at start
feat: not ending with dot.
feat: too long of a commit message is not allowed over 71 characters long
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);