use strict;
my $str = 'feat(api): this is great
vim-patch:supportsanything
fix!: breaking change support
feat: No uppercase at start
feat: not ending with dot.
feat: too long of a commit message is not allowed over 71 characters long
';
my $regex = qr/^(?=.{0,72}$)(vim-patch.*|(fix|feat|docs|test|perf|refactor|chore|build)(\([^)]+\))?!?:\s[a-z].*[^.]$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}