import re
regex = re.compile(r"^(?=.{0,72}$)(vim-patch.*|(fix|feat|docs|test|perf|refactor|chore|build)(\([^)]+\))?!?:\s[a-z].*[^.]$)", flags=re.MULTILINE)
test_str = ("feat(api): this is great \n"
"vim-patch:supportsanything\n"
"fix!: breaking change support\n"
"feat: No uppercase at start\n"
"feat: not ending with dot.\n"
"feat: too long of a commit message is not allowed over 71 characters long\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")