const regex = /^(?=.{0,72}$)(vim-patch.*|(fix|feat|docs|test|perf|refactor|chore|build)(\([^)]+\))?!?:\s[a-z].*[^.]$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{0,72}$)(vim-patch.*|(fix|feat|docs|test|perf|refactor|chore|build)(\\([^)]+\\))?!?:\\s[a-z].*[^.]$)', 'gm')
const str = `feat(api): this is great
vim-patch:supportsanything
fix!: breaking change support
feat: No uppercase at start
feat: not ending with dot.
feat: too long of a commit message is not allowed over 71 characters long
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}