# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|(?<=[a-z]))([A-Z].*)\1{1,}
/\1/img;t' <<< "
The quick brown ox jumps over the lazy dogThe quick brown fox jumps over the lazy dog
ApplesApplesApples
IBM AT Computer
Lamp ShadeLamp Shade
OrangesOranges
I am a Potato
EXAMPLEEXAMPLE
ProblemExample
"