#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(?:^|(?<=[a-z]))([A-Z].*)\1{1,}" & @CRLF & _
""
Local $sString = "" & @CRLF & _
"The quick brown ox jumps over the lazy dogThe quick brown fox jumps over the lazy dog" & @CRLF & _
"ApplesApplesApples" & @CRLF & _
"IBM AT Computer" & @CRLF & _
"Lamp ShadeLamp Shade" & @CRLF & _
"OrangesOranges" & @CRLF & _
"I am a Potato" & @CRLF & _
"EXAMPLEEXAMPLE" & @CRLF & _
"ProblemExample" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)