import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=[a-z]))([A-Z].*)\\1{1,}\n";
final String string = "\n"
+ "The quick brown ox jumps over the lazy dogThe quick brown fox jumps over the lazy dog\n"
+ "ApplesApplesApples\n"
+ "IBM AT Computer\n"
+ "Lamp ShadeLamp Shade\n"
+ "OrangesOranges\n"
+ "I am a Potato\n"
+ "EXAMPLEEXAMPLE\n"
+ "ProblemExample\n\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}