# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?:^|(?<=[a-z]))([A-Z].*)\1{1,}\n")
test_str = ("\n"
"The quick brown ox jumps over the lazy dogThe quick brown fox jumps over the lazy dog\n"
"ApplesApplesApples\n"
"IBM AT Computer\n"
"Lamp ShadeLamp Shade\n"
"OrangesOranges\n"
"I am a Potato\n"
"EXAMPLEEXAMPLE\n"
"ProblemExample\n\n")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.