const regex = /(?:^|(?<=[a-z]))([A-Z].*)\1{1,}
/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|(?<=[a-z]))([A-Z].*)\\1{1,}
', 'img')
const str = `
The quick brown ox jumps over the lazy dogThe quick brown fox jumps over the lazy dog
ApplesApplesApples
IBM AT Computer
Lamp ShadeLamp Shade
OrangesOranges
I am a Potato
EXAMPLEEXAMPLE
ProblemExample
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);