re = /(?:^|(?<=[a-z]))([A-Z].*)\1{1,}
/im
str = '
The quick brown ox jumps over the lazy dogThe quick brown fox jumps over the lazy dog
ApplesApplesApples
IBM AT Computer
Lamp ShadeLamp Shade
OrangesOranges
I am a Potato
EXAMPLEEXAMPLE
ProblemExample
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result