#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-z0-9\.]+@[A-z]+\.[a-z]+"
Local $sString = "@%$$^#$%" & @CRLF & _
"" & @CRLF & _
"geek.pro@hotmail.org" & @CRLF & _
"" & @CRLF & _
"nano_alpha@go.in" & @CRLF & _
"" & @CRLF & _
"ramsesxiii2@gmail.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"dsowtr#spi9e.ee" & @CRLF & _
"" & @CRLF & _
"034903" & @CRLF & _
"" & @CRLF & _
"name :" & @CRLF & _
"Ramsesxiii" & @CRLF & _
"" & @CRLF & _
"age : 34" & @CRLF & _
"" & @CRLF & _
"bla bla" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")