const regex = /[A-z0-9\.]+@[A-z]+\.[a-z]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-z0-9\\.]+@[A-z]+\\.[a-z]+', 'gm')
const str = `@%\$\$^#\$%
geek.pro@hotmail.org
nano_alpha@go.in
ramsesxiii2@gmail.com
dsowtr#spi9e.ee
034903
name :
Ramsesxiii
age : 34
bla bla
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}