package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-z0-9\.]+@[A-z]+\.[a-z]+`)
var str = `@%$$^#$%
geek.pro@hotmail.org
nano_alpha@go.in
ramsesxiii2@gmail.com
dsowtr#spi9e.ee
034903
name :
Ramsesxiii
age : 34
bla bla
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}