re = /[A-z0-9\.]+@[A-z]+\.[a-z]+/m
str = '@%$$^#$%
geek.pro@hotmail.org
nano_alpha@go.in
ramsesxiii2@gmail.com
dsowtr#spi9e.ee
034903
name :
Ramsesxiii
age : 34
bla bla
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end