import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-z0-9\\.]+@[A-z]+\\.[a-z]+";
final String string = "@%$$^#$%\n\n"
+ "geek.pro@hotmail.org\n\n"
+ "nano_alpha@go.in\n\n"
+ "ramsesxiii2@gmail.com\n\n\n"
+ "dsowtr#spi9e.ee\n\n"
+ "034903\n\n"
+ "name :\n"
+ "Ramsesxiii\n\n"
+ "age : 34\n\n"
+ "bla bla\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}