$re = '/[A-z0-9\.]+@[A-z]+\.[a-z]+/m';
$str = '@%$$^#$%
geek.pro@hotmail.org
nano_alpha@go.in
ramsesxiii2@gmail.com
dsowtr#spi9e.ee
034903
name :
Ramsesxiii
age : 34
bla bla
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);