# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(sst=[^&]+&)|((\?|&|^)sst=[^&]+$)//gm;t' <<< "eg.com
eg.com?sst=12
eg.com?sst=12&from=nothing
eg.com?from=nothing&sst=12
eg.com?from=nothing&sst=12&to=nowhere
sst=12
sst=12&from=nothing
from=nothing&sst=12"