import Foundation
let pattern = #"(sst=[^&]+&)|((\?|&|^)sst=[^&]+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
eg.com
eg.com?sst=12
eg.com?sst=12&from=nothing
eg.com?from=nothing&sst=12
eg.com?from=nothing&sst=12&to=nowhere
sst=12
sst=12&from=nothing
from=nothing&sst=12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)