package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(sst=[^&]+&)|((\?|&|^)sst=[^&]+$)`)
var str = `eg.com
eg.com?sst=12
eg.com?sst=12&from=nothing
eg.com?from=nothing&sst=12
eg.com?from=nothing&sst=12&to=nowhere
sst=12
sst=12&from=nothing
from=nothing&sst=12`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}