import re
regex = re.compile(r"(sst=[^&]+&)|((\?|&|^)sst=[^&]+$)", flags=re.MULTILINE)
test_str = ("eg.com\n"
"eg.com?sst=12\n"
"eg.com?sst=12&from=nothing\n"
"eg.com?from=nothing&sst=12\n"
"eg.com?from=nothing&sst=12&to=nowhere\n"
"sst=12\n"
"sst=12&from=nothing\n"
"from=nothing&sst=12")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)