// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(sst=[^&]+&)|((\?|&|^)sst=[^&]+$)").unwrap();
let string = "eg.com
eg.com?sst=12
eg.com?sst=12&from=nothing
eg.com?from=nothing&sst=12
eg.com?from=nothing&sst=12&to=nowhere
sst=12
sst=12&from=nothing
from=nothing&sst=12";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}