#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[а-яёіА-Я])a|a(?=[а-яёіА-Я])|(?<=\s)a(?=\s)"
Local $sString = "Пpи прямoй ингаляции маслa вдыхаютcя из флакона, или c салфетки, нa которую наносят несколькo капель. Этoт спосoб даeт болеe сильный эффект, чeм аромакурительница." & @CRLF & _
"" & @CRLF & _
"слова o словах"
Local $sSubst = "а"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)