import Foundation
let pattern = #"(?<=[а-яёіА-Я])a|a(?=[а-яёіА-Я])|(?<=\s)a(?=\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Пpи прямoй ингаляции маслa вдыхаютcя из флакона, или c салфетки, нa которую наносят несколькo капель. Этoт спосoб даeт болеe сильный эффект, чeм аромакурительница.
слова o словах
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"а"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)