use strict;
my $str = 'Пpи прямoй ингаляции маслa вдыхаютcя из флакона, или c салфетки, нa которую наносят несколькo капель. Этoт спосoб даeт болеe сильный эффект, чeм аромакурительница.
слова o словах';
my $regex = qr/(?<=[а-яёіА-Я])a|a(?=[а-яёіА-Я])|(?<=\s)a(?=\s)/mp;
my $subst = 'а';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";