import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[а-яёіА-Я])a|a(?=[а-яёіА-Я])|(?<=\\s)a(?=\\s)";
final String string = "Пpи прямoй ингаляции маслa вдыхаютcя из флакона, или c салфетки, нa которую наносят несколькo капель. Этoт спосoб даeт болеe сильный эффект, чeм аромакурительница.\n\n"
+ "слова o словах";
final String subst = "а";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}