re = /(?<=[а-яёіА-Я])a|a(?=[а-яёіА-Я])|(?<=\s)a(?=\s)/m
str = 'Пpи прямoй ингаляции маслa вдыхаютcя из флакона, или c салфетки, нa которую наносят несколькo капель. Этoт спосoб даeт болеe сильный эффект, чeм аромакурительница.
слова o словах'
subst = 'а'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result