$re = '/(?<=[а-яёіА-Я])a|a(?=[а-яёіА-Я])|(?<=\s)a(?=\s)/m';
$str = 'Пpи прямoй ингаляции маслa вдыхаютcя из флакона, или c салфетки, нa которую наносят несколькo капель. Этoт спосoб даeт болеe сильный эффект, чeм аромакурительница.
слова o словах';
$subst = "а";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;