#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}(?:(?:\.\d{2}){3}|\d{6})$"
Local $sString = "12.45.7810" & @CRLF & _
"12345678" & @CRLF & _
"12.34.56.78" & @CRLF & _
"1.234.56.78" & @CRLF & _
"12.45.7816 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")