// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{2}(?:(?:\.\d{2}){3}|\d{6})$").unwrap();
let string = "12.45.7810
12345678
12.34.56.78
1.234.56.78
12.45.7816 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}