import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{2}(?:(?:\\.\\d{2}){3}|\\d{6})$";
final String string = "12.45.7810\n"
+ "12345678\n"
+ "12.34.56.78\n"
+ "1.234.56.78\n"
+ "12.45.7816 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}