package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}(?:(?:\.\d{2}){3}|\d{6})$`)
var str = `12.45.7810
12345678
12.34.56.78
1.234.56.78
12.45.7816 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}