using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{2}(?:(?:\.\d{2}){3}|\d{6})$";
string input = @"12.45.7810
12345678
12.34.56.78
1.234.56.78
12.45.7816 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}